Some Customers are reporting they are unable to sync or view data in the Back Office

Incident Report for Epos Now

Resolved

This incident has been resolved. We apologise for any inconvenience this may have caused.
Posted Nov 08, 2025 - 04:30 GMT

Update

We have identified the issue and are working on a resolution.
Posted Nov 08, 2025 - 03:55 GMT

Investigating

We are currently investigating the issue.
Posted Nov 08, 2025 - 02:40 GMT
This incident affected: EPOS NOW HQ BACK OFFICE and EPOS NOW FRONT TILL.