Eat Out to Help Out
Incident Report for Epos Now
Resolved
This incident has been resolved.
Posted Jan 14, 2021 - 15:10 GMT
Investigating
Our Eat Out to Help Out App has helped over 1.5million diners. In line with Government Policy the Scheme has now ended but please keep the App Installed for your reporting in your Back Office. All reporting is retained and if you accidentally uninstall the App, simply reinstall it from your AppStore and your reporting will still be supported.
For queries on how to best manage a similar discount scheme with your Epos, and other Frequently asked questions, please visit https://www.eposnow.com/eatout
Posted Sep 02, 2020 - 11:24 BST
This incident affected: EPOS NOW HQ BACK OFFICE.