Front Till Loading
Incident Report for Epos Now
Resolved
This incident has been resolved.
Posted Nov 29, 2022 - 11:40 GMT
Monitoring
We have received reports of problems with Front Till loading.

If you are experiencing this issue, please close and reopen the Epos Now Till App
Posted Nov 29, 2022 - 08:38 GMT
This incident affected: EPOS NOW FRONT TILL.