Reporting Outage
Incident Report for Epos Now
Resolved
This incident has been resolved.
Posted May 06, 2022 - 16:11 BST
Monitoring
A fix has been implemented and we are monitoring the system's health.
Posted May 04, 2022 - 15:53 BST
Investigating
We are currently aware of an issue with accessing reports for all users. We have identified the issue and are working to implement a fix.
Posted May 03, 2022 - 09:59 BST
This incident affected: EPOS NOW HQ.