Cloud sync degraded performance
Incident Report for Epos Now
Resolved
Performance of Cloud Sync is stable and fully operational.
Posted Oct 19, 2024 - 14:28 BST
Monitoring
A fix has been applied and our teams are currently monitoring Cloud Sync performance.
Posted Oct 19, 2024 - 14:20 BST
Investigating
Out team has identified some instances of degraded Cloud Sync performance for some customers. We are currently investigating the root cause and will provide updates via our status page.

For further updates and support please visit our Live Chat section of support.eposnow.com
Posted Oct 19, 2024 - 14:08 BST
This incident affected: EPOS NOW FRONT TILL.