Stuck on loading screen (Blue Screen)
Incident Report for Epos Now
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 15:25 BST
Update
Please refresh or restart your till app and your normal till screen will display. We are continuing to monitor to incident.
Posted Oct 15, 2020 - 09:10 BST
Monitoring
We beleive the issue with loading the till app and being stuck on a blue screen is now resolved and we are continuing to monitor.
Posted Oct 15, 2020 - 09:02 BST
This incident affected: EPOS NOW HQ BACK OFFICE.