POS Till App Failure: Windows Device's

Incident Report for Epos Now

Resolved

This issue should now be resolved.
Please go ahead and restart youe till app if it is stuck on loading when being ran on a windows device

Give our support line a call if you expierience any further issues
Posted Nov 05, 2025 - 17:22 GMT

Update

We have completed rolling out an update to address the issue preventing a subset of users from accessing the windows pos app.
If you continue to be affected, please restart your till app, after which the till should load correctly. We are continuing to monitor the situation.
Posted Nov 05, 2025 - 17:22 GMT

Update

Our engineering team have identified the issue and have started a rollout to occur over the next 10 mins with the fix

Please go ahead and restart the till app and give us a call if this issue is still occuring.
Posted Nov 05, 2025 - 17:12 GMT

Monitoring

Our team Has identified the issue affecting windows devices running the front till app.
We have implemented a fix to address the root cause
But in order for it take affect customers must clear their app cache, if you are unsure how to do so,

Please call into our support line and one of our support reps will be able to perform the above.

Our team is working on a method to resolve the issue without manual action
Further updates to follow
Posted Nov 05, 2025 - 17:02 GMT

Investigating

We have found certain customers being unable to access the front till app via their windows device.
For now, please use alternative devices such as android devices to access the front till app
Our team is currently investigating the issue, further updates will follow
Posted Nov 05, 2025 - 16:44 GMT
This incident affected: EPOS NOW FRONT TILL.