Epos Now Payments - Degraded Performance
Incident Report for Epos Now
Resolved
We can confirm that the root cause of the issue affecting in-person payment transactions has been resolved.

We will continue monitoring and provide a new update if required.
Posted Oct 24, 2023 - 10:24 BST
Investigating
We have identified an issue resulting in degraded performance for a subset of in-person payment transactions.

Our engineering team has been engaged and is actively working on resolving this issue.

Please reach out via support.eposnow.com if you have any questions.
Posted Oct 24, 2023 - 10:22 BST
This incident affected: EPOS NOW PAYMENTS.