Our platform is continuously monitored for outages, slowdowns, or other issues. Should there be any interruptions in service or a software release, we'll provide status updates here. Subscribe via SMS or Email and
never miss an update again.
Get email notifications whenever Epos Now creates, updates or resolves an incident.
Get text message notifications whenever Epos Now creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Our communications partner has confirmed that this issue has now been resolved
Customers should now be able to contact the support line
Please contact us if you face any further issues
Posted Oct 16, 2025 - 04:38 BST
Update
- We are currently facing performance degradation causing calls to drop from our supprot line - Our communications partner has made some changes and some calls should be able to come through now via our contact line
- Further updates to come but some calls may still drop, if so, please use our live chat functionality via our supprot center - support.eposnow.com/s/live-chat
Posted Oct 15, 2025 - 20:16 BST
Update
- We are facing degraded performance of our support line, we are working with our communications partner to resolve this outage - Again, for any merchants needing suppot please use our live chat function via the support center, via: support.eposnow.com/s/live-chat
Posted Oct 15, 2025 - 18:48 BST
Update
- We are currently expirencing degraded performance on our Support Line - Our team have identified this as an issue caused by an outage with our communications partner - This issue may cause an attempt to call our support line to disconnect
- For now, please use our Live chat functionality in order to receivie support with any issues you encounter via: - support.eposnow.com/s/live-chat
Posted Oct 15, 2025 - 17:59 BST
Update
We are continuing to work on a fix for this issue.
Posted Oct 15, 2025 - 17:54 BST
Identified
- We are currently expirencing degraded performance on our Support Line - Our team have identified this as an issue caused by an outage with our communications partner - This issue may cause an attempt to call our support line to disconnect
- For now, please use our Live chat functionality in order to receivie support with any issues you encounter