Till App Loading
Incident Report for Epos Now
Resolved
This incident has now been resolved.
Posted May 09, 2023 - 11:51 BST
Identified
We are currently aware of an issue with the loading of the Till App, our engineering team is working on a fix.
Posted May 09, 2023 - 10:08 BST
This incident affected: EPOS NOW FRONT TILL.