Our platform is continuously monitored for outages, slowdowns, or other issues. Should there be any interruptions in service or a software release, we'll provide status updates here. Subscribe via SMS or Email and
never miss an update again.
Get email notifications whenever Epos Now creates, updates or resolves an incident.
Get text message notifications whenever Epos Now creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
If you have any further issues please give us a call, thank you
Posted Nov 12, 2025 - 23:29 GMT
Monitoring
We have gone ahead and applied the fix on our end preventing access to the back office and causing issues on the front till
Please go ahead and restart your till app / refresh the web page, and it should resolve the issue.
If you come across any further issuesd please give us a call, We are currently monitoring this issue.
Posted Nov 12, 2025 - 22:51 GMT
Identified
We have identified the isse and it appears to be affecting more customers preventing cloud sync from occuring, as well as preventing access to any new world pages
Posted Nov 12, 2025 - 22:41 GMT
Update
We are still investigating the root cause of this issue, please look towards further updates and give us a call if you run into any issues
Posted Nov 12, 2025 - 22:26 GMT
Update
We are currently experiencing issues affecting some front till systems. A subset of customers may encounter difficulties with accessing the table plan
Impact: Partial - Some till systems affected
We apologize for any inconvenience and appreciate your patience as we work to resolve this issue.
Posted Nov 12, 2025 - 22:07 GMT
Investigating
We are currently investigating an issue around windows tills becoming stuck upon initial load