Payment gateway provider is experiencing technical issues
Incident Report for Epos Now
Resolved
We have confirmation from our payment gateway partner that the incident is now resolved.
Posted Mar 16, 2023 - 21:35 GMT
Monitoring
Our payment gateway provider is experiencing technical issues.

They have identified an issue resulting in intermittent connectivity issues and degraded performance for merchants connecting to global endpoints starting at 20:15 CET.

Their engineering team has been engaged and is actively trying to resolve the situation.
Posted Mar 16, 2023 - 20:27 GMT
This incident affected: EPOS NOW PAYMENTS.