Windows Application Access
Incident Report for Epos Now
Resolved
This incident has been resolved. A further status update will follow.
Posted May 19, 2022 - 09:05 BST
Update
If you are experiencing an issue where your windows till is stuck on "loading", please download and install our most recent POS app from: https://tinyurl.com/posinstall3412
Posted May 06, 2022 - 19:32 BST
Investigating
We are currently aware of an issue relating to accessing the POS app for some Windows customers and are investigating.
Posted May 06, 2022 - 11:19 BST
This incident affected: EPOS NOW HQ BACK OFFICE.