Epos Now Till App - Partial Outage

Incident Report for Epos Now

Resolved

This incident should now be resolved, and all merchants affected should be able to enter the till app.

If you are still experiencing this issue
Please reboot your till, and give us a call if you experience any further issues.

Thank you for your patience!
Posted May 09, 2025 - 23:40 BST

Monitoring

A fix has been implemented, we are monitoring to see if this issue is still occurring.
Please close and re-open the till app and give us a call if the issue is still occurring
Posted May 09, 2025 - 23:01 BST

Investigating

We are currently investigating the issue where the till app is not opening and instead showing "server error in '/' application"
In the meantime, please attempt to access the till app via another device.

Our on-call team is on it.
Posted May 09, 2025 - 22:42 BST
This incident affected: EPOS NOW FRONT TILL.