Back Office Loading
Incident Report for Epos Now
Resolved
This incident has now been resolved.
Posted Mar 15, 2023 - 11:33 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2023 - 10:55 GMT
Investigating
We have currently identified an issue for a small subset of users where they may experience issues accessing some sections of the Back Office. We are investigating this issue and will update you accordingly.
Posted Mar 15, 2023 - 10:08 GMT
This incident affected: EPOS NOW HQ BACK OFFICE.