Our platform is continuously monitored for outages, slowdowns, or other issues. Should there be any interruptions in service or a software release, we'll provide status updates here. Subscribe via SMS or Email and
never miss an update again.
Get email notifications whenever Epos Now creates, updates or resolves an incident.
Get text message notifications whenever Epos Now creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
A fix has been deployed, and our engineering team is actively monitoring the results to ensure full stability. Epos Now Payments and Back Office services should now be operating as expected. We will continue to keep a close watch and provide a further update once the issue is fully resolved.
Posted Sep 16, 2025 - 22:26 BST
Update
Our team is still investigating the issue. We are making progress towards identifying the underlying cause and will provide further updates as soon as more information becomes available. Customers should continue to use Standalone Mode for processing transactions in the meantime.
Posted Sep 16, 2025 - 22:22 BST
Update
We continue to investigate the issue and our engineering team is actively working to determine the root cause. For Epos Now Payments, we recommend continuing to process transactions using Standalone Mode.
Posted Sep 16, 2025 - 22:03 BST
Update
We are working to identify the issue and our engineering team is working to identify the cause. For Epos Now Payments we recommend processing transactions using Standalone Mode.
Posted Sep 16, 2025 - 21:35 BST
Investigating
We are currently investigating an issue where an error occurs upon attempt to process a card transaction It appears to be affecting a subset of customers
please use standalone for right now in order to process transactions
Posted Sep 16, 2025 - 21:17 BST
This incident affected: EPOS NOW HQ BACK OFFICE and EPOS NOW PAYMENTS.