Till App Loading Error
Incident Report for Epos Now
Resolved
All services are now operational, we will continue to monitor for any changes.

For more support please visit support.eposnow.com/s/livechat
Posted Nov 23, 2023 - 16:42 GMT
Monitoring
Our team have applied a fix, restoring performance to Epos Now Front Till. You may experience slower than usual Cloud Sync while our Database stabilizes again.

Back Office reporting is temporary disabled.

For further information or support, please visit: support.eposnow.com/s/livechat
Posted Nov 23, 2023 - 14:31 GMT
Identified
We continue to see degraded performance and partial outage across some users.

Our team is once again working on resolving the issue along with our database partner as soon as possible.

For more support please visit support.eposnow.com/s/livechat
Posted Nov 23, 2023 - 13:27 GMT
Update
We are continuing to monitor for any further issues.
Posted Nov 23, 2023 - 12:10 GMT
Monitoring
Our team & Database partner have successfully resolved the issue impacting this incident.

We will continue to closely monitor the situation and will update accordingly if anything changes.

For further information or support, please visit: support.eposnow.com/s/livechat
Posted Nov 23, 2023 - 12:08 GMT
Identified
Currently we are seeing errors for 20-30% of our users. We are waiting on our Database partner to resolve the issues with the database.

As soon as ETA's are available we will update here.

Please do not attempt factory resets on the till devices as some information may be lost until the till has performed a successful Cloud Sync.

For more support please visit support.eposnow.com/s/livechat
Posted Nov 23, 2023 - 10:47 GMT
Investigating
We are aware of an issue affecting one of our databases which is causing errors when loading the till front. Our engineering team are currently working with our database partners on identifying a fix.
Posted Nov 23, 2023 - 08:01 GMT
This incident affected: EPOS NOW HQ BACK OFFICE and EPOS NOW FRONT TILL.