Till App Loading
Incident Report for Epos Now
Resolved
This incident has been resolved.
Posted Jul 25, 2023 - 14:00 BST
Monitoring
We have identified an issue with Cloud Sync and Till App loading, we have implemented a fix and are monitoring the results.
Posted Jul 25, 2023 - 13:33 BST
This incident affected: EPOS NOW FRONT TILL.