Reduced UK Phone Line Support
Incident Report for Epos Now
Resolved
This incident has been resolved.
Posted Nov 17, 2023 - 17:16 GMT
Identified
We are aware of issues for our UK customers connecting to our contact centre via telephone, our partner is working on deploying a fix. Please visit our support centre to access our live chat service to be connected to an agent immediately.
Posted Nov 17, 2023 - 15:11 GMT