Our platform is continuously monitored for outages, slowdowns, or other issues. Should there be any interruptions in service or a software release, we'll provide status updates here. Subscribe via SMS or Email and
never miss an update again.
Get email notifications whenever Epos Now creates, updates or resolves an incident.
Get text message notifications whenever Epos Now creates or resolves an incident.
Get incident updates and maintenance status messages in Slack.
Performance of Cloud Sync is stable and fully operational.
Posted Oct 06, 2024 - 15:08 BST
Monitoring
A fix has been applied and our teams are currently monitoring Cloud Sync performance.
Posted Oct 06, 2024 - 13:58 BST
Investigating
Out team has identified some instances of degraded Cloud Sync performance for some customers. We are currently investigating the root cause and will provide updates via our status page.
For further updates and support please visit our Live Chat section of support.eposnow.com